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1. Introduction 
 
These notes are an overview on the calibration tools provided by the Field System. The data 
acquisition programs (ONOFF and ACQUIR) will be illustrated very quickly, while a more detailed 
description about the off-line data analyzer (GNPLT) will be given. 
 
2. Our goal: the amplitude calibration of the telescope 
 
When can we say that our telescope is well calibrated? The answer to this question is very simple but 
it is not so easy to realize: when calibration parameters - TCal(K) and the combination of DPFU and 
the gain curve - can predict the TCal(Jy) measured observing a source of known flux density. This 
target can be obtained through a process that should be executed regularly. This process begins with 
the measurements of a new set of TCal(Jy) by the use of ONOFF. This data are then checked to see if 
they are consistent with the present calibration parameters. If they are not, GNPLT permits to change 
them according to the results of ONOFF. 
Every receiver installed on your telescope should be checked during each EVN session because VLBI 
data reliability is much dependant on the accuracy of the calibration parameters of each participating 
station; in fact the derivation of Tsys information for actual observation (Antab files) is based on them. 
 
3. Quantities description 
 
Here follows a brief description of the quantities involved in the calibration process: 
 

I. TCal(K) - Noise calibration mark in Kelvin degrees. This calibration parameter is stored into 
.rxg files. 

II. TCal(Jy) - Noise calibration mark in Janskies. It's given by 
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where Fsource is the flux density of a known source. 
III. DPFU(K/Jy) - Degrees Per Flux Unit. This calibration parameter is the maximum height of the 

gain curve. 
IV. SEFD(Jy) - System Equivalent Flux Density, which is, in brief, the system temperature in 

Janskies. 
V. Gain Compression -This is obtained calculating the ratio of the variation in counts switching 

the cal on when on source, to the change in counts when off source. This ratio should be 
close to one as much as possible. If this does not happen, any other measured parameter is 
likely to be unreliable. For instance, the presence of RFI could affect this value. 

VI. TCalRatio - This is a derived quantity. It is the ratio of measured TCal(Jy) by ONOFF to the 
one predicted by calibration parameters. This provides a useful indication of how well your 
telescope is calibrated. 

VII. Trec(K) - Receiver temperature in Kelvin degrees. 
VIII. Tspill(K) - The system temperature contribution due to spillover. 

IX. Airmass - Defined as )sin(
1

elevation . 

 
4. Setting up the data acquisition 
 
The data acquisition is performed scheduling ONOFF as many times as required. Generally, if you are 
focused only on TCal(K) measurements, a number of sources should be used at an adequate 
elevation otherwise, if you are interested in the determination of the gain curve, a source should be 
tracked along its full elevation path until a complete 0-90 range is completed. In the former case it 
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must be taken into consideration that the receiver bandwidth should be sampled with as narrow as 
possible sub-bands in order to map the TCal(K) versus frequency more accurately. 
A convenient way to run ONOFF automatically is AQUIR, this software cycles around a list of sources, 
launching ONOFF (also FIVEPT) for each of them.  
There are several steps required before starting the data acquisition.  
 
4.1 The .rxg files 
 
Every time the Field System starts, all files in the directory /usr2/control/rxg_files that have the .rxg 
extension are opened. Within these files the FS expects to find all current parameters and calibration 
data for each receiver. These data will be used by the Tsys  calculation, by ONOFF and by GNPLT. 
Appendix 1 reports a .rxg template for the S band provided together with the Field System package. 
The information (please see the comments in the example for details) are stored in this order: 

• Local oscillator in MHz.  
• Last modification date. 
• Beamwidth format. 
• Available polarizations. 
• DPFUs, for each polarization. 
• Gain polynomial coefficients. 
• TCal(K) table versus the frequency. 
• The receiver temperature TRec. 
• The spill-over table versus elevation. 

If your receiver has never been calibrated before, you are requested to provide initial values for all the 
parameters stored in the .rxg file. Attention must be paid to ensure that the effective Local Oscillator 
settings within the .rxg file match the LOs value issued by the LO command in the Field System. You 
should also make sure that all the other values are appropriate; for example, a good Tcal(K) initial 
value could be the one measured in the laboratory.  
 
4.2 The flux.ctl file 
 
The file flux.ctl can be found inside the directory /usr2/control/.  
It is unlikely that you will ever have to deal with this file; nevertheless it is important to know that 
ONOFF deduces the flux density of the calibrators from this file. So if you want to obtain consistent 
data from a source, it must have an entry within this file for the proper wavelength.  
For completeness:  

• The flux density versus the wavelength can be computed using this formula: 
)(log)(log)(log 2

101010 MHzcMHzbaJyS νν ⋅+⋅+=  
• The source size (arc seconds) is also reported 
• A model of the brightness distribution of the source is used to calculate a correction factor 

together with the FWHM of the telescope. 
 
4.3 Onoff 
 
A detailed section that describes the onoff snap command, used to initialize and run the ONOFF 
program can be found in the Field System help file (?=onoff ). For example the command: 
 onoff=4,5,75.0,3.0,450,allvc,i1 
configures 4 repetitions with 5 seconds of integration time, the off-source positioning is performed in 
elevation above 75 degrees of elevation, the off-source steps are 3 beamwidths, the on-source flag is 
waited for 450 seconds and the measurements are done using all VCs reported by the patch 
command plus the IF1. Special characters like ‘*’ are allowed as well. 
As a result of the onoff command (no arguments) the ONOFF program starts and outputs (see 
appendix 2 for an example) 9 types of record that are listed below: 
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• APR (a priori) summarizes the devices involved and gives details about initial parameters: 
supposed gain, expected source flux. 

• ORIG reports the seconds elapsed since midnight and the present offsets in X-Y, AZ-EL, RA-
DEC. 

• ONSO reports for each device the average during the integration period of the TPI when the 
antenna is on-source. 

• ONSC reports for each device the average during the integration period of the TPI when the 
antenna is on-source and the calibration diode is fired. 

• OFFC reports for each device the average during the integration period of the TPI when the 
antenna is off-source and the calibration diode is fired. 

• OFFS reports for each device the average during the integration period of the TPI when the 
antenna is off-source. 

• ZERO reports for each device the average during the integration period of the TPI when all the 
attenuators are switched on. 

• SIG stores the uncertainties of the measures reported in VAL records. 
• VAL reports the final results of the ONOFF repetitions; respectively, source name, average of 

azimuth and elevation, device mnemonic, IF chain, polarization, Gain Compression, Tsys, 
SEFD(Jy), TCal(Jy), TCalRatio. 

It must be noticed that ONOFF needs that the procedures calonnf and calofnf are present in the 
current procedure file loaded by the Field System. 
 
4.4 Automatic data acquisition 
 
The calibration experiments are usually carried out using ONOFF and FIVEPT (if you want to minimize 
the pointing errors before the measurements), in combination with AQUIR. AQUIR is a program that 
eases not only the automatic acquisition of calibration data but also the customization of many 
parameters according to station constraints.  
In order to use AQUIR the user has to prepare a control file (usually in /usr2/control/ ). An example of 
such a control file can be found in appendix 3. In this file there is a list of calibrators, for each of them 
above the horizon, AQUIR performs some configurations and runs the selected tasks. For details 
about the meaning of each field in the control file, see the comments in the example. It must be 
noticed that: 

• The coordinates (RA, DEC, EPOCH) are not used to point the antenna but to check if the 
source is above the cutoff elevation, so you must make sure that the Field System knows how 
to command that source. 

• All the procedures used inside the control file must be present in the current procedure file. 
Usually the sequence of commands to start the calibration is: 
 sy=run aquir /usr2/control/[your-control-file].ctl & 
 log=calibration 
 
5. GaiN PLoT 
 
The remaining part of this document is a short "how to" guide to GNPLT. Please remember this is not 
meant to be a complete user manual. 
 
GNPLT is a Tcl/Tk program distributed together with the Field System in order to help to examine and 
to analyze the accuracy of the amplitude calibration of a telescope. A good calibration depends on 
how accurately the TCal(Jy) is predicted, thanks to the combination of gain curve and TCal(K) versus 
frequency. 
These calibration parameters are stored in the control .rxg files; GNPLT allows updating this 
information starting from a Field System log file containing ONOFF data. 
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5.1. Plotted quantities 
 
GNPLT is mostly focused on calibration parameters but it is also capable to plot many others versus 
variables like frequency, elevation, azimuth, airmass and time. All these quantities could be splitted 
into two groups: measured quantities and derived quantities. 
 
5.1.1. Calibration parameters 
 
Calibration parameters are loaded from .rxg files at start. In order to prevent modifications by accident, 
GNPLT copies these files into working files. DPFU, gain curve polynomial, TCal(K) belong to this 
group. While running GNPLT, these parameters are fitted and changed to new values that can be 
stored again in working files. Before exiting GNPLT, you can decide whether to update the calibration 
parameters into the .rxg file with the ones present in the current working file, or not. 
 
5.1.2. Measured quantities 
 
When a log file is opened, GNPLT imports these quantities from ONOFF records (VAL). The most 
important ones are SEFD(Jy), TCal(Jy) and Gain Compression. These values never change during 
GNPLT sessions. TCal(K) and TCalRatio are also reported by ONOFF but they are recalculated by 
GNPLT every time that new calibration parameters are fitted. 
 
5.1.3. Derived quantities 
 
Derived quantities are calculated by GNPLT from measured quantities and also from calibration 
parameters. Gain, for instance, is calculated dividing the TCal(K) by the measured TCal(Jy). 
 
5.2. Starting GNPLT 
 
A main program composes this software: GNPLT, which is the GUI that displays all the data and 
permits all the user operations over them. GNPLT makes use of two other programs: GNDAT and 
GNFIT. 
GNDAT takes care of parsing the log file and extracting all the relevant data. GNFIT performs the 
curves fitting and returns the curve polynomial, the RMS, and the number of iterations needed. 
In order to start the program it is sufficient to run the GUI. At the command prompt of your Field 
System machine type gnplt. GNPLT can also accept two command line arguments, one is -r which 
forces the program to auto-replot every time the user makes selections on plot axes, the second one 
is the log file name. 
 
5.3. The 'File' menu 
 
5.3.1. Opening a log file 
 
The first method is the command line argument as described before. Another way to open a log file is 
to select the 'New' menu item. A window will open,it lets you select the file name and its location. If the 
file you selected is valid, GNPLT begins to parse the log by running GNDAT. When this process is 
completed successfully the status bar of the main window should say 'Ready'. During this stage all 
menus are also set up. 
 
5.3.1. Printing 
 
GNPLT is capable to print the plots in the encapsulated postscript format (eps). On the 'File' menu 
there is the 'Print' menu item that allows printing the current plot. A new window labeled 'print plot' will 
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open; if you select 'printer' as destination, the 'lpr' command will be used to print the plot, if you choose 
'file' the output will be the file specified in the 'Filename' entry field. If no directory is specified, the 
current directory is used. 
 
5.4. Selecting the axes and plotting quantities 
 
Before you can plot anything, you have to choose the items for the X and Y axes. On the 'Items(X-
Axis)' menu you have five different options that are self-explaining: Time, Elevation, Frequency, 
Azimuth, and Airmass. The 'Items(Y-Axis)' menu consists of three sections. First, there are the 
standard quantities from the log file. Then, you have the 'Assumed Items' with all the information 
reported by the .rxg file. Finally, you have the 'Gain' cascade menu, which has four additional options 
that differ in how the gain is calculated. This section is a little bit more complicated and it will be 
discussed later. 
 
5.5. Replotting 
 
When you have selected what is to be plotted you will have to replot. This could be done by either 
clicking the 'Replot' menu item on the 'Edit' menu or by pressing the 'r' key on your keyboard. The 
replot could also be performed automatically: if you start GNPLT with flag '-r' on the command line or if 
you select 'Yes' on the cascade menu 'Auto Replot' located on the 'Edit' menu, GNPLT will 
automatically replot every time you change the axes. 
 
5.6. Selecting sources and frequencies 
 
By default GNPLT plots all the observed frequencies and sources in the log file. This case is very 
rarely needed, so GNPLT allows you to select specific sources and frequencies. 
 
5.6.1. Source selection 
 
On the 'Select Source' cascaded menu located on the 'Edit' menu there are four items: 

I. 'All' - Select all the sources. 
II. 'All Calibrators' - Select all sources that are calibrators. 

III. 'All Calibrators & Pointing' - Select all calibrators and pointing sources. 
IV. 'None' - No sources at all. 

If you want to be more detailed, a sub menu for each source is added. This menu(s) lists all the times 
that the source was observed; by clicking these check buttons you can add/remove these scans from 
the plot. 
 
5.6.2. Polarization selection 
 
On the 'Edit' menu there are two cascade menus, one for the 'Left' polarization, one for the 'Right' 
polarization. On each of them there are three command buttons: 

I. 'All' - Select all frequencies for that polarization. 
II. 'No Left'/'No Right' - Deselect all frequencies for that polarization. 

III. 'No Left or Right' - Deselect all frequencies for both polarizations. 
Below the command buttons there is a variable number of buttons labeled with LO values; this number 
depends on how many LOs are present in your log file. Clicking one of them selects and deselects all 
the frequencies associated to that LO. Finally, you can find as many check buttons as the number of 
frequencies observed. These check buttons report also the mnemonic of the device/detector. With 
these widgets you can switch the associated frequency on and off. 
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5.7. Highlighting 
 
5.7.1. Highlighting sources 
 
All the sources in the log file will be displayed as radio buttons on the 'Source' menu. There is also a 
radio button for 'All' sources. When you click on one of these radio buttons all the points for that 
source are highlighted (that means they are filled with black ink). In case you replot or select 'All' they 
turn white again. 
On the 'Source' menu there is also the cascade menu 'Select Display' that allows to control how the 
data points are displayed inside the plot: 

I. 'Points' - Data are displayed as circles. 
II. 'Letters' - Data are represented by a letter in the same position in which the points would 

normally be. 
III. 'Points and Letters' - This is the default; data are displayed as a combination of circles and 

letters. 
It must be noted that just right of the plotting area there is a box, labeled 'Source Legend', indicating 
which source each letter is associated with. 
 
5.7.2. Highlighting frequencies 
 
The 'Frequencies' menu works just as the 'Source' menu. All the currently plotted frequencies are 
associated with a radio button. Clicking the radio button will highlight all the points with that frequency. 
 
5.8. Scaling 
 
The scaling functionalities are accessible through the 'Scaling' menu. This menu controls the 
conditions on which the limits of both the axes are set. The default is to let GNPLT choose the limits 
for you. 
 
5.8.1. Autoscaling 
 
There are two different types of autoscaling on the 'Scaling' menu. For both options GNPLT will set the 
axes limits depending on what the user has selected on the 'Edit' menu. If you choose to 'Autoscale 
Including Deleted', all points matching your selection will be used to calculate axes limits, on the 
contrary if you choose to 'Autoscale Not Including Deleted', all deleted (see section 5.9) points will be 
left out. 
 
5.8.2. Manual scaling 
 
The radio button 'Manual' on the 'Scaling' menu allows you to set axes limits. A new window, showing 
the current limits, will open. You are now enabled to change what you prefer and when the 'Ok' button 
is pressed the selected limits are used. Before applying these limits some checks are performed, so if 
you inserted bad values (i.e. the maximum is smaller than minimum) you'll get an error message on 
the status bar. You also might want to zoom an area, this can be done using the left mouse button and 
dragging a rectangle, the selected region will be displayed in more detail. 
 
5.9. Data editing 
 
Often, in order to obtain a good fitting and so a better accuracy for calibration parameters it is 
necessary to delete some points that are noisy. A deleted point is not included in the input data of the 
fitting routine. A point status is described by its color: 

I. White - the point is included, i.e. the point fits the user selection and is not deleted (clicked) 
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II. Red - the point is deleted 
III. Black - the point is highlighted. 
IV. Blue - the point is selected but it is outside the plotting limits, it is drawn on the plot borders. 

Next to the plot there is the information box. This box reports information on how many points have 
been highlighted (see section 5.7), selected (points that are inside the user selection), included (points 
that are selected and not deleted) and finally on how many points are present in the log file. 
 
5.9.1. Mouse editing 
 
Moving the mouse cursor close to a point on the plot all the data related to that point are displayed on 
the right side of the main window, including time, frequency, polarization, etc. 
Clicking on a point turns it red, i.e. the point is deleted from calculations. If you want to throw away a 
group of points just draw a box with the right mouse button around them. If the 'Shift' key is pressed 
while deleting a point, all the observations that have the same time will be deleted. If you want to 
restore a deleted point it is sufficient to click on it again. A group of points could be undeleted by 
dragging an area with the middle mouse button. 
 
5.9.2. Editing out the bad data 
 
As already discussed the Gain Compression could be a good indication on whether the data are 
reliable or not. The fastest way to discard the bad data based on Gain Compression is to click the 
"Delete points with bad GC" on 'Edit' menu. A window opens, where you can select the upper and 
lower thresholds, beyond which data are rejected. This operation is highly recommended before any 
further analysis. 
 
5.9.3. Deleting point outside plot 
 
If you want all points outside the current plot limits to be deleted, you can achieve this by the 'Delete 
points outside plot' on the 'Edit' menu. 
 
5.9.4. Undelete points 
 
Sometimes you may want to restore all previously deleted points and to display again the points 
outside the limits. This operation is particularly useful when the display, for some reason, doesn't quite 
respond to your request. The quickest way to do this is to use the command 'Undelete All For This 
Selection' on 'Edit' menu. The 'Undelete All Points in Log' command does the same except for the fact 
that it also clears all user selections done via the 'Edit' menu. 
 
6. The calibration parameters 
 
In order to get accurate calibration for VLBI you will need to tune DPFU or/and TCal(K) versus 
frequency. If the model given by the combination of both these parameters is not consistent, then the 
prediction of the TCal(Jy) will be different from the one measured by ONOFF using a source of known 
flux density. For VLBI purposes you could focus only one between DPFU and TCal(K), but ideally you 
should choose to tune both these parameters and to describe your system as close to reality as 
possible. 
Generally speaking you should update the parameter you are more doubtful about, i.e. the parameter 
that mostly differs from what you expect. 
 
7. Checking gain curve and DPFU 
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The first step you need is to select the polarization and LO on 'Edit' menu. Please notice that although 
left and right polarization share the same gain curve polynomial they have different DPFUs. This 
means that once you fitted the gain curve for one polarization the other must share the same curve. 
The second step is to plot Gain versus elevation. The gain is a derived quantity and is calculated from 
TCal(Jy) in the log file and an assumed TCal(K). The 'Gain' drop down menu on 'Items(Y-axis)' menu 
gives three choices on where to obtain this TCal(K): 

I. 'TCal from working file' - This is the more common choice, the TCal will be read from the 
working file. 

II. 'TCal from user input' - A single value can be inserted manually and it will be the same for all 
the frequencies. 

III. 'Specify gain for elev. range' - The TCal(K) will be set to a value such that the gain will have a 
certain mean value over a range of elevations. 

Last two choices were provided in order to allow the user to input data taken from external calibrations 
(for example from calculating the antenna gain from its area and efficiency). 
Having done this two operations the 'Tools' menu is now populated by the tools needed to fit a gain 
curve: 

I. 'Gain Curve in working file' - switching on/off this check button displays/removes the gain curve 
from working file (solid green line). 

II. 'Fitted Gain Curve' - switching on/off this check button displays/removes the fitted gain 
curve(dashed black line). The combination of these two commands is very useful to compare 
the old curve with the new one and decide whether to update the working file or not. 

III. 'Fit to' - This item is a cascade submenu where there are three different fitting options: 
a.  'New DPFU' - the existing gain curve in the .rxg working file will be used to calculate a 

new DPFU for the current polarization. 
b. 'Gain Curve and DPFU' - A dialog window will appear. In that box you will be able to 

select the degree of the curve polynomial and the type of the gain curve (ALTAZ or 
ELEV). The result is a new gain curve and DPFU for that polarization. 

c. 'Scale TCal(K) - This will cause the TCal(K) in the working file to be scaled by a factor. 
This factor is the average of the gain divided by DPFU times the gain curve, averaged 
over all the points. 

IV. 'Update Working File' - This will update the .rxg working file with the last fit. After the updating, 
the last fitted curve turns green since it is now the curve in the .rxg working file. 

The step-by-step check list you need to obtain gain curve and DPFU from your data, is: 
I. Open a log file. 

II. Delete bad data using Gain compression. 
III. Select source(s). 
IV. Select a polarization. 
V. Plot Gain(using TCal(K) from working file) versus elevation. 

VI. Delete noisy points. 
VII. Fit a new gain curve and DPFU. 

VIII. If you are satisfied, update the working file. 
IX. Select the other polarization. 
X. Replot. 

XI. Delete noisy points. 
XII. Fit for a new DPFU. 

XIII. If you are satisfied, update the working file. 
XIV. Done. Before exiting, remember to update the original .rxg file if you want to store new 

parameters definitively. 
 
8. Checking TCal(K) versus frequency 
 
Also in this case one polarization should be analyzed at a time. After plotting TCal(K) versus 
frequency you can use the options under the 'Tools' menu: 
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I. 'TCal(K) curve in file' - switching on/off this check button displays/removes the TCal(K) curve 
from working file (solid green line). 

II. 'Fitted TCal(K) curve' - switching on/off this check button displays/removes the fitted gain 
curve(dashed black line). Basically these two commands work in the same way the buttons for 
the gain curve do. 

III. 'Fit for TCal(K)' - This item is a cascade submenu where there are two different options: 
a. 'Average at each freq.' - GNPLT will average the TCal(K) value at each frequency and 

then draw a line(dashed black line) between these points. 
b. 'Median at each freq.' - GNPLT will calculate the median(average of the two middle 

values) of the TCal(K) values at each frequency and then draw a line(dashed black 
line) between these points. 

IV. 'Update working file' - This will update the .rxg working file with the last fitted TCal(K) table. 
After the updating, the last fitted curve turns green since it is now the curve in the .rxg working 
file. 

The step-by-step checklist, you need to obtain gain curve and DPFU from your data, is: 
I. Open a log file. 

II. Delete bad data using Gain compression. 
III. Select source(s). 
IV. Select a polarization. 
V. Plot TCal(K) versus frequency. 

VI. Delete noisy points. 
VII. Fit a new TCal(K) table for the current polarization. 

VIII. If you are satisfied, update the working file. 
IX. Select the other polarization. 
X. Replot. 

XI. Delete noisy points. 
XII. Fit a new TCal(K) table for the current polarization. 

XIII. If you are satisfied, update the working file. 
XIV. Done. Before exiting, remember to update the original .rxg file if you want to store new 

parameters definitively. 
 
9 Opacity corrected gain 
 
GNPLT allows you to correct your data for opacity (τ). This capability makes sense only if you are 
analyzing data acquired at frequencies greater than 8 GHz. In fact, doing an opacity correction at 4/5 
cm or higher will probably make your calibration worse. 
This feature will only be available if the receiver temperature Trec(K) is included in your .rxg file. The 
spillover table versus elevation should also be supplied. Anyway this last information is optional and it 
could be missing. In that case Tspill(el)=0 will be assumed by GNPLT. 
GNPLT make use of this formula: T . For each data point the  

is found. The opacity corrected gain is then e  times the uncorrected gain. In order to enable this 
feature the radio button 'Correct for opacities' should be clicked. This button is on 'Gain' cascade 
menu already described in section 12. The program will then prompt the user for the Tatm(K). The 
ambient temperature at the moment of the observation 280k is often used. A corrected gain curve is 
obtained by fitting in the same way as usual. The curve polynomial in the .rxg file will be marked by the 
tag 'opacity_corrected'. 

)1()()( τ−−++= eTelTTel atmspillrecsys

τ−
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9.1 Fitting for Trec(K) 
 
Opacity correction are clearly very dependant on having a good Trec(K). GNPLT allows you to check if 
the value of the assumed Trec(K) is consistent by comparing it with an estimation from your data. If 
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you plot Tsys-Tspill versus airmass, the 'Tools' menu is set up with the commands you will need to fit 
a new Trec and to update working file, if needed: 

I. 'Mark Trec from working file' - This check button displays/removes the current Trec(K) marker. 
If the marker is off the plot limits, a message will appear on the status bar. 

II. 'Mark fitted Trec' - This check button displays/removes the last fitted Trec(K) marker. If there is 
no fitted Trec(K) a message will appear on the status bar. 

III. 'Fit for Trec' - You will be asked to insert the Tatm and a time interval over which the 
atmospheric opacity is supposed to be constant. Data from each time segment will be fitted by 
the curve T , where τ0 is the zenith opacity. If your data is 
collected during N hours and you choose a K hours interval, then |N/K| curves are calculated 
and drawn. The point where the single curve intercepts for airmass=0 (Y-axis) will be the 
estimation of Trec(K) for that time interval. The final estimated Trec(K) will be the weighted 
mean of all these Trec(K). 

)1( 0 Airmass
atmrecspillsys eTTT ⋅−+=− τ

IV. 'Recalculate Trec' - This command can be used to recalculate the weighted mean after some 
editing (i.e. Trecs could be deleted as normal data points). 

V. 'Update working file' - This will update the .rxg working file with computed Trec(K). 
 
10. Shortcut methods 
 
Under the 'Edit' menu you can find three shortcuts for plotting gain versus elevation, TCal(K) versus 
frequency and Tsys-Tspill versus airmass. These commands should speed up editing and selection 
but what is plotted is more restricted than if using the general method. For example, for gain versus 
elevation only a single frequency (detector) can be plotted and the needed TCal(K) is always taken 
from the working file. 
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Appendix 1. Example .rxg file 
 
* s.rxg - s band receiver parameter definition 
* 
* first line: LO values and ranges, format: 
*  type   frequencies 
* if type is range, the two values: lower and upper frequencies 
* if type is fixed, then the fixed value 
* frequencies in MHz 
* 
fixed 2020 
* 
* 2nd line: creation date 
* format:  yyyy ddd or yyyy mm dd (0 is valid for all for intial set-up) 
* 
2002 07 18 
* 
* 3rd line: FWHM beamwidthm format: 
*   model value 
* 
* if type is frequncy, then fwhm=value*1.22*c/(freq*diameter) 
*                      value is 1.0 if omitted 
* if type is constant, then fwhm=value (degrees) 
* 
frequency 1.0 
* 
* 4th line polarizations available 
* 
* one of both of lcp and rcp 
* 
rcp 
* 
* 5th line: DPFU (degrees/Jansky) for polarizations in previous line in order 
* 
  0.00126 
* 
* 6th line: gain curve (only one) for ALL polarizations in 4th line 
* TYPE FORM COEFFICENTS ... [opacity_corrected] 
* 
* FORM = POLY only for now 
* TYPE - ELEV and ALTAZ only for now 
* COEFFICENTS - variable number of number values 
* opacity_corrected - optional final field, if present it indicates that 
*                     the curve is opacity corrected 
* 
* maximum coefficents 10 
* 
ELEV POLY 1.0  
* 
* 7th and following lines: tcal versus frequency 
*     Format: POL FREQ TCAL 
*     where: 
*            POL    polarization rcp or lcp 
*            FREQ   frequency (MHz) 
*            TCAL   degrees K 
* 
*     ends with a line containing end_tcal_table 
* 
*     MAXIMUM ENTRIES 400, group by polarization 



*                          then sorted by increasing freq 
* 
rcp 2080.0  8.3  
end_tcal_table 
* 
* Trec: receiver temperature 
* 
0.0 
* 
* Spill over table 
* 
* 9th and following lines: Spillover versus frequency 
*     Format: Elevation Tspill 
*     where: 
*            POL    polarization rcp or lcp 
*            FREQ   frequency (MHz) 
*            TCAL   degrees K 
* 
*     ends with a line containing end_spillover_table 
* 
*     MAXIMUM ENTRIES 20 
end_spillover_table 
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Appendix 2. extract of a log file 
 
2006.048.14:11:15.36#onoff#    De    Center  TCal    Flux    DPFU     Gain    Product   LO    T   FWHM 
2006.048.14:11:15.37#onoff#APR 5u  22213.00 27.44    16.4  0.118661 0.88588  0.105119 21964.00 c 0.02948 
2006.048.14:11:15.37#onoff#APR 6u  22213.00 25.49    16.4  0.114000 0.88588  0.100990 21964.00 c 0.02948 
2006.048.14:11:15.37#onoff#APR i1  22264.00 32.46    16.4  0.118661 0.88588  0.105119 21964.00 c 0.02941 
2006.048.14:11:15.37#onoff#APR i2  22264.00 30.26    16.4  0.114000 0.88588  0.100990 21964.00 c 0.02941 
 
2006.048.14:12:27.46#onoff#ORIG 51145.1   0.00000   0.00000   0.00000   0.00000   0.00000   0.00000 
 
2006.048.14:12:34.02#onoff#ONSO     6.7   0.00000   0.00000 5u   8583.8      2.3 6u  10739.2      4.8 
2006.048.14:12:34.02#onoff#ONSO     6.7   0.00000   0.00000 i1  14814.6      0.8 i2  18391.6      1.2 
 
2006.048.14:12:42.93#onoff#ONSC    15.7   0.00000   0.00000 5u  10025.8      2.9 6u  12343.4      2.6 
2006.048.14:12:42.93#onoff#ONSC    15.7   0.00000   0.00000 i1  17773.8      4.5 i2  21577.2      5.4 
 
2006.048.14:12:56.58#onoff#OFFC    29.3   0.21649   0.00000 5u   9944.2      4.4 6u  12245.6      3.3 
2006.048.14:12:56.58#onoff#OFFC    29.3   0.21649   0.00000 i1  17623.8      0.7 i2  21414.0      1.8 
 
2006.048.14:13:05.51#onoff#OFFS    38.2   0.21649   0.00000 5u   8496.6      1.8 6u  10635.8      3.0 
2006.048.14:13:05.51#onoff#OFFS    38.2   0.21649   0.00000 i1  14658.6      1.2 i2  18216.6      1.4 
 
2006.048.14:13:12.14#onoff#ZERO    44.8   0.21649   0.00000 5u   1020.2      0.2 6u   1767.6      0.3 
2006.048.14:13:12.14#onoff#ZERO    44.8   0.21649   0.00000 i1    878.4      0.3 i2    823.6      0.7 
 
2006.048.14:15:52.42#onoff#SIG                 5u                0.02  1.99    1.1  55.661 5.851  0.21 
2006.048.14:15:52.42#onoff#SIG                 6u                0.02  2.05    1.2  54.195 5.473  0.21 
2006.048.14:15:52.42#onoff#SIG                 i1                0.02  1.93    0.9  68.295 7.179  0.22 
2006.048.14:15:52.42#onoff#SIG                 i2                0.02  2.24    1.2  71.291 7.200  0.24 
2006.048.14:15:52.42#onoff#    source       Az   El  De I P   Center   Comp   Tsys  SEFD  Tcal(j) Tcal(r) 
2006.048.14:15:52.42#onoff#VAL dr21       289.9 46.1 5u 1 l  22213.00 1.0076 142.8 1411.3 271.155 1.0384 
2006.048.14:15:52.42#onoff#VAL dr21       289.9 46.1 6u 2 r  22213.00 1.0074 141.2 1414.2 255.322 1.0113 
2006.048.14:15:52.42#onoff#VAL dr21       289.9 46.1 i1 1 l  22264.00 1.0070 152.1 1450.1 309.342 1.0016 
2006.048.14:15:52.42#onoff#VAL dr21       289.9 46.1 i2 2 r  22264.00 1.0067 166.1 1644.3 299.589 0.9997 
2006.048.14:15:52.42#onoff#    source       Az   El  De I P   Center   Comp   Tsys  SEFD  Tcal(j) Tcal(r) 
 



Appendix 3. Example of a control file for AQUIR. 
 
* CTLPO.CTL control file for AQUIR for Medicina LL primary focus rec. 
* last edition: GMM 11 April 1995 
*  First data record:  
*  
*   Setup procedure, Setup wait, Terminate Procedure, Terminate wait,  
*  
*                    Upper elevation Limit, ONSOURCE Wait, 
*  
*                    Amount to lead source when calculating what's up  
* 
*         Sources outside elevation limits are considered 'down' 
* 
   INITPLLP  -1 INITPLLP -2 85 500 600 
* 
* Elevation mask for lower elevation limit: AZ EL AZ EL ... AZ 
* may contain multiple lines, an incomplete line ends with an EL 
* 
   0 10 360 
* 
*  Source records: 
* 
*    Name, R.A., Dec., Epoch, Preob procedure, Preob wait, 
* 
*          FIVPT wait, ONOFF wait, PEAKF wait, 
* 
*          Postob procedure, Postob Wait 
* 
*  The nominal maximum number of sources is 200, but it may vary. 
*  If there are too many in the file, the program will print a 
*  message with the current number. 
* 
 3C84       031629.54  411951.7 1950 PREP    -1  0  15  0 POSTP    -2 
 3C161      062443.2  -055112.  1950 PREP    -1  20  0  0 POSTP    -2 
 2134P004   213405.23  002825.0 1950 PREP    -1 20  0  0 POSTP    -2 
 3C123      043355.2   293414.  1950 PREP    -1  0  15  0 POSTP    -2 
 1921M293   192142.18 -292024.9 1950 PREP    -1 20  0  0 POSTP    -2 
 0521M365   052113.2  -363019.  1950 PREP    -1 20  0  0 POSTP    -2 
*TAURUSA    053131     215900   1950 PREP    -1 20  5  0 POSTP    -2 
*ORIONA     053249.   -052515   1950 PREP    -1 20  5  0 POSTP    -2 
 3C147      053843.52 +494942.2 1950 PREP    -1  0  15  0 POSTP    -2 
*0552P398   055201.4   394822   1950 PREP    -1 20  0  0 POSTP    -2 
 0521M365   052113.2  -363019.  1950 PREP    -1 20  0  0 POSTP    -2 
 1921M293   192142.18 -292024.9 1950 PREP    -1 20  0  0 POSTP    -2 
 2134P004   213405.23  002825.0 1950 PREP    -1 20  0  0 POSTP    -2 


